Splunk Search

グラフに表示するプロット数の上限値の変更方法

Splunk_Shinobi
Splunk Employee
Splunk Employee

グラフに表示するデータのプロット数の上限値の変更方法を教えて下さい。

Tags (2)
0 Karma
1 Solution

melonman
Motivator

以下をXMLに記述して調整してみてください。

<chart>
...
<option name="charting.data.count">4000</option>
<option name="charting.chart.resultTruncationLimit">3000</option>
...
</chart>

http://docs.splunk.com/Documentation/Splunk/6.1.1/Viz/ChartConfigurationReference

charting.data.count
The number of results to retrieve. Set to 0 to get all results.

charting.chart.resultTruncationLimit
Override default rendering limits for the total number of objects plotted in a chart. These apply to cartesian (dual axis) charts. [column: 1200, bar: 1200, line: 2000, area: 2000]

View solution in original post

0 Karma

masagara8823
Explorer

上記を参考に設定してみましたが、下記のエラー回避ができません。
These results may be truncated. Your search generated too much data for the current visualization configuration
データ取得は日次で定型フォーマットの種類数が186の値を取得しています。
プロット数のデフォルトが1000とのことですが、
疑問として、
1.日次データの増減に関わらず、サーチ文のlimit=0からある程度の一定に数に変更しないとエラーが回避できない事。
2.「 50000」が有効にならない事です。
どうぞ、ご教示ください。

0 Karma

melonman
Motivator

以下をXMLに記述して調整してみてください。

<chart>
...
<option name="charting.data.count">4000</option>
<option name="charting.chart.resultTruncationLimit">3000</option>
...
</chart>

http://docs.splunk.com/Documentation/Splunk/6.1.1/Viz/ChartConfigurationReference

charting.data.count
The number of results to retrieve. Set to 0 to get all results.

charting.chart.resultTruncationLimit
Override default rendering limits for the total number of objects plotted in a chart. These apply to cartesian (dual axis) charts. [column: 1200, bar: 1200, line: 2000, area: 2000]

View solution in original post

0 Karma