Splunk Enterprise

Why an error when running the command, /opt/Splunk/bin/Splunk reload deploy-server -class on the deployment server?

Loves-to-Learn Lots

I am trying to run a Linux bash script on the deployment server to pull down the deployment clients.
I have the Splunk command correct, but get an authentication error when this is run under cron or even from the command line.
There are multiple postings on this command, but none of them talk about requiring authentication.

How do we work around the account password issue?
Splunk 8.2.3

command: Splunk reload deploy-server -class

I tried the -auth parameter that is shown on other command options, but this one does not seem to like this option.

command: splunk reload deploy-server -class
results: Your session is invalid. Please login.
Splunk username: admin

An authentication error occurred: Client is not authenticated

Any guidance would be appreciated.

Labels (1)
0 Karma


Hi @raghunandan1 

have you tried using deafult admin password changeme 

if default password doesnt work, you might need to reset the password 

1. please rename the cuurent passwd to passwd_old , under location $SPLUNK_HOME/etc/passwd
2. go to $SPLUNK_HOME$/system/local create a new file user-seed.conf
3. update follwing details
USERNAME = admin
PASSWORD = changeme 

4.restart the splunk. $SPLUNK_HOME/bin/splunk restart

after above steps you can able to run reload server class and able to authenticate


0 Karma
Get Updates on the Splunk Community!

Splunk APM & RUM | Upcoming Planned Maintenance

There will be planned maintenance of the streaming infrastructure for Splunk APM and Splunk RUM in the coming ...

Part 2: Diving Deeper With AIOps

Getting the Most Out of Event Correlation and Alert Storm Detection in Splunk IT Service Intelligence   Watch ...

User Groups | Upcoming Events!

If by chance you weren't already aware, the Splunk Community is host to numerous User Groups, organized ...