Splunk Enterprise

Unable to create new indexes directly on Splunk Web(UI) after adding Smartstore Indexes. "New Index" Button Disabled?

sushainmagotra1
Observer

Hello,

I recently migrated few of my Indexes to Smartstore Indexes using Azure. After the migration, now when I go to the Indexes page on my Splunk Web UI, the "New Index" button is disabled and it says "Disabled new index for Smart store Indexes".

Does this mean I cannot create any new Splunk Indexes via Splunk Web directly now, or is it a bug? How can I re-enable the "New Index" button now?

(I am using Splunk Enterprise verson 9.0.1 and a single instance)

0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

my expectation is that as you cannot add needed information to use S2 with GUI it has disabled for that reason. You must add indexes by conf files after you have enabled S2.

That is told on https://docs.splunk.com/Documentation/Splunk/9.0.1/Indexer/AddSmartStoreindextocluster

r. Ismo

0 Karma

sushainmagotra1
Observer

Hi  r.Ismo,

Thanks for your reply. But what if I want to add a non smart store index ( a normal splunk index). For that also now I have to use indexes.conf every time?

So that means once Smart store is activated for even one index, we cannot add even non smart store indexes through GUI?

0 Karma

isoutamo
SplunkTrust
SplunkTrust
Exactly that way.
0 Karma
Get Updates on the Splunk Community!

Platform Highlights | November 2022 Newsletter

 November 2022 Skill Up on Splunk with our New Builder Tech Talk SeriesCan you build it? Yes you can! *play ...

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...

Five Subtly Different Ways of Adding Manual Instrumentation in Java

You can find the code of this example on GitHub here. Please feel free to star the repository to keep in ...