Splunk Enterprise Security

tstats issue in ES 2.4.0 ...

Communicator

Hello,

I have noticed that tscollect/tstats in ES 2.4.0 gives very strange results:

  1. The "Host With Multiple Infections" notable event (based on the sa_malware namespace) appear regularly on the dashboard even if the corresponding correlation search is disabled!! Also, the result of this specific notable event is completely wrong when comparing with the results of the malware macro (the "Host With Multiple Infections" search is based on the malware macro).
    I have tried to enable the correlation search but I still see new wrong results in the notable events. Disabling it again, doesn't change anything.

  2. I have another problem with the sa_malware namespace this time giving me less results than expected. In the dashboard, in the Endpoint > Malware Center, the "Top Infected System" panel for instance gives me only one result (and a wrong one!) while there is plenty of infected system when the run the malware macro (with the stats used to generate this result).

The "Endpoint - All Malware - Base" saved search is running as scheduled (this is what is populating the sa_malware namespace).

Finally, (another strange behaviour), running " | tstats dc(signature) from sa_malware groupby dest " will mention 3 matching events below the search bar but "no matching event" in the result area!

Would anyone knows how I can debug this tscollect/tstats?

Regards,
Olivier

Communicator

Hi David,

Thank you for your answer. I have opened a case with Splunk regarding this as it might be a complex one. I will update the thread when we manage to solve it.

Regards,
Olivier

0 Karma

Builder

OL,

One of the most common reasons for discrepancies between accelerated (summaries indexes OR TSIDX) and raw data are abnormalities between the time at which the event is indexed, and the extracted timestamp. Is this data being collected in near real time < 5 minutes from when the events occured? Are there any errors in the logs that would indicate the "Endpoint - All Malware - Base" is not completing successfully? I think a support case is probably going to be your best vehicle for getting this resolved.

Thanks,
David

Communicator

Hi David,

Thank you for your answer. I have opened a case with Splunk regarding this as it might be a complex one. I will update the thread when we manage to solve it.

Regards,
Olivier

0 Karma