Splunk Enterprise Security

Vulnerbaility data model information is mismatch with datamodel acceleration

raghu_yara
New Member

Hi,

using this query
| from datamodel:"Vulnerabilities"."Vulnerabilities" |stats count by signature getting result 234
using this query
| tstats summariesonly=true values(Vulnerabilities.signature) as vuln_count from datamodel=Vulnerabilities.Vulnerabilities
| mvexpand vuln_count
getting result 194.
So that dashboards are getting wrong information Splunk enterprise security app. Please help me where I did mistake.

0 Karma

xpac
SplunkTrust
SplunkTrust

The values() option only gives you each value once.
If signature exists more than once, it's only contained once in the result (like an implicit dedup). Therefore, you might less results than by simply counting them.
Use list() instead of values(), that should fix it.

Hope that helps.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...