Splunk Enterprise Security

Splunk Enterprise Security: Using Splunk 6.5.1, why is the app's navigation layout broken?

season88481
Contributor

Hi guys,

Anyone ever seen this:
alt text

When I load the Splunk page, the navigation bar at the top looks OK. Then I load the Splunk Enterprise Security (ES) app, the navigation layout just changed to something strange and cannot restore automatically.

Also the drop-down list is not showing anything.

Cleaned cache and cookies, NO joy.
Switch to a different browser, still the same issue.

Browser I am using:
IE11(Version 11.0.9600.18524)
Firefox: 19.0.5 (Tried 50.1.0 as well)

Any idea will be much appreciated.

Thanks.

0 Karma
1 Solution

LukeMurphey
Champion

LukeMurphey
Champion

ES 4.1.0 only supports Splunk 6.3.3 through 6.4.x (see http://docs.splunk.com/Documentation/ES/4.1.0/RN/Enhancements).

Upgrade to ES 4.1.3 (http://docs.splunk.com/Documentation/ES/4.1.3/RN/Enhancements) or ES 4.5.1 (http://docs.splunk.com/Documentation/ES/4.5.1/RN/Enhancements) to get it to work with Splunk 6.5.1.

season88481
Contributor

That sounds like the problem.

Will give it a try. Thanks a lot.

0 Karma

season88481
Contributor

Updated: upgrade ES to 4.5.1 fixed the issue. Thanks a lot for your help. 😉

0 Karma

kchamplin_splun
Splunk Employee
Splunk Employee

The other thing to check is to ensure your JS and CSS files are loading - often you can see errors for this in the "console" view of your browser. For FireFox to "tools>web developer>web console" and see if there are any errors being produced there. I have seen this behavior before as well with things like Ad-bocker Plus, so turn off any ad-blocker browser plugins just as a quick test.

0 Karma

rpille_splunk
Splunk Employee
Splunk Employee

What version of Enterprise Security are you running on what version of the Splunk platform? Have you checked that your version of ES is supported on the version of the Splunk platform you are using?

season88481
Contributor

Thanks rpille.

Splunk version: 6.5.1
ES version: 4.1.0

I can only see ES 4.1.3 and 4.0.5 available on the splunk base. So I assume 4.1.0 should work fine with splunk 6.5.1 as well?

0 Karma
Get Updates on the Splunk Community!

BSides Splunk 2022 - The Call for Papers is now Open!

TLDR; Main Site: https://bsidessplunk.com CFP Site: https://bsidessplunk.com/cfp CFP Opens: December 15th, ...

Sending Metrics to Splunk Enterprise With the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

What's New in Splunk Cloud Platform 9.0.2208?!

Howdy!  We are happy to share the newest updates in Splunk Cloud Platform 9.0.2208! Analysts can benefit ...