Splunk Enterprise Security
Highlighted

Splunk Enterprise Security: After upgrading, why do I receive error "Install cannot continue because some apps are configured to deny disablement"?

Splunk Employee
Splunk Employee

upgraded Splunk Enterprise Security (ES) from v4.5.2 and after restarting Splunk and navigating to the ES app, we receive the error:

"Install cannot continue because some apps are configured to deny disablement: SA-IdentityManagement,SAThreatIntelligence,SplunkTAwindows,SplunkTAsourcefire,DA-ESS-ThreatIntelligence,DA-ESS-NetworkProtection,SA-EndpointProtection,DA-ESS-IdentityManagement,DA-ESS-EndpointProtection,DA-ESS-AccessProtection,SplunkSACIM,SA-AccessProtection,SplunkSAExtremeSearch,SA-UEBA,SA-Utils,TA-nmap,SplunkTAoracle,SplunkTAnix,SA-AuditAndDataProtection,SplunkTAossec,SA-NetworkProtection"

0 Karma
Highlighted

Re: Splunk Enterprise Security: After upgrading, why do I receive error "Install cannot continue because some apps are configured to deny disablement"?

Splunk Employee
Splunk Employee

To resolve the issue, try the step listed below:

[install]
allows_disable=true

Please do the same for all the apps that listed with the aboved errors and re-tried the upgrade

Splunkd daemon is not responding: (u"Error connecting to /services/apps/local/SA-IdentityManagement/enable: ('The read operation timed out',)",)
To fix this one, try the following step:
vi /opt/splunk/etc/apps/SA-IdentityManagement/local/app.conf
[install]
allows_disable = true
state = enabled <----deleted this line

Splunkd daemon is not responding: (u"Error connecting to /services/apps/local/DA-ESS-ThreatIntelligence/disable: ('The read operation timed out',)",)
To fix this one, try the following step:
vi /opt/splunk/etc/apps/SA-ThreatIntelligence/local/app.conf
[install]
allows_disable = true
state = disabled <-----------removed this line
saved & restarted splunk
ran setup again

View solution in original post