Splunk Enterprise Security

Ip location return a wrong location after update db

saveriobocca
Loves-to-Learn Lots

Hi all,
I have Splunk ESS Version: 7.1.3.

After updating the GeoLite2-City.mmdb db (last 17/3/20) I noticed that in my query the location is still wrong.

Example:

index=network eventtype=cisco_vpn_start "AnyConnect parent session started." 
| where src_ip ="37.161.xx.xxx"
| iplocation src_ip 
| table src_ip, Country

src_ip  Country
37.161.xx.xxx   France

However when I running the following command:

| makeresults 
| eval ip="37.161.xx.xxx" 
| iplocation ip
| table Country, ip

Country   ip
Italy       37.161.xx.xxx

Why in one case is the correct value returned to me (Italy) while in the first case France appears to me?
The behavior is very anomalous to me 😞

Do you have any suggestion or fix for first query?

Thanks a lot,
Saverio

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...