Splunk Enterprise Security

How can I do a graph with multiple data?

christianubeda
Path Finder

Hi team!

It's my very first time here and I need a bit of help!

I want to make a graph with multiple lanes.

I have this right now. 1 graph per data. I want to fusion them but I don't know how.

Graph 1.

index=xxx_paloalto sourcetype="pan:threat"  type=threat threat_name="SCAN: TCP Port Scan(8001)"
 (src_zone!="Inet-WAN1" AND src_zone!="Inet-WAN2")
 (dest_zone!="Inet-WAN1" AND dest_zone!="Inet-WAN2") 
 src_ip != xxx
| stats by src_ip, dest_ip, _time
 | bin  _time span=1d
 | stats count by _time

Graph 2

index=xxx_paloalto sourcetype="pan:threat"  type=threat threat_name="SCAN: Host Sweep(8002)"
 (src_zone!="Inet-WAN1" AND src_zone!="Inet-WAN2")
 (dest_zone!="Inet-WAN1" AND dest_zone!="Inet-WAN2") 
 src_ip != xxx
| stats by src_ip, dest_ip, _time
 | bin  _time span=1d
 | stats count by _time

Thanks!

0 Karma

kmorris_splunk
Splunk Employee
Splunk Employee

Give this a try. I am assuming you want a line for each combination of src_ip, dest_ip, and threat_name based on your search above. By the way, you are missing a function in your stats command. Something like count, avg, min, max, etc... Either way, I created a field that concatenates the src_ip, dest_ip, and threat_name so you can get a line for each in a line graph for example. I hope this helps.

index=xxx_paloalto sourcetype="pan:threat" type=threat (threat_name="SCAN: TCP Port Scan(8001)” OR threat_name=“SCAN: Host Sweep(8002)”)
(src_zone!="Inet-WAN1" AND src_zone!="Inet-WAN2")
(dest_zone!="Inet-WAN1" AND dest_zone!="Inet-WAN2") 
src_ip != xxx
| eval byfield=src_ip . "," . dest_ip . "," . threat_name
| bin _time span=1d
| chart count over _time by byfield
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...