Splunk Enterprise Security

Connection not secure : splunk web with https when using internal cert

Ksr1982
Explorer

My settings in web.conf

enableSplunkWebSSL = True
privKeyPath = /opt/splunk/etc/auth/myxxx/private.key
serverCert = /opt/splunk/etc/auth/myxxx/web.pem (conatins server cer, Intermediate ca and root ca)
requireClientCert = false

 

Getting error in browser > NET::ERR_CERT_COMMON_NAME_INVALID

splunkd.log

SSLCommon - Received fatal SSL3 alert. ssl_state='SSLv3 read client key exchange A', alert_description='certificate unknown'.
HttpListener - Socket error from x.x.x.x:xxxx while idling: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown

 

All configuration seems correct. anyone resolved similar issue.

 

 

Labels (1)
Tags (2)

jackal713
Path Finder

Did you ever get any where on this issue?

I have the same symptom (NET::ERR_CERT_COMMON_NAME_INVALID) but I have a different error in my splunkd.log

Just in case anyone is wondering, the error I'm getting is "WARN HttpListener - Socket error from 127.0.0.1:6252 while idling: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number"

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...