Splunk Enterprise Security

Batch input. How to index .tar files quickly?

rendie
Path Finder

Hi,

I have batch index with next configuration:

[batch://path/to/files]
move_policy = sinkhole
index = maindata
 
And if in folder "files" are .csv files, then they will be indexed in seconds. But if in the folder are .tar.gz archive with CSV file inside, then he will be indexed only after restart Splunk.
 
How to index archive some quickly as .csv files?
 
Thanks.
0 Karma
1 Solution

scelikok
SplunkTrust
SplunkTrust

Hi @rendie,

If you are putting the tar.gz files with the same name, this may be the reason you need to restart. 

Please try adding below check modified time setting and try;

[batch://path/to/files]
move_policy = sinkhole
CHECK_METHOD = modtime
index = maindata

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.

View solution in original post

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @rendie,

If you are putting the tar.gz files with the same name, this may be the reason you need to restart. 

Please try adding below check modified time setting and try;

[batch://path/to/files]
move_policy = sinkhole
CHECK_METHOD = modtime
index = maindata

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma
Get Updates on the Splunk Community!

Introducing the Splunk Community Dashboard Challenge!

Welcome to Splunk Community Dashboard Challenge! This is your chance to showcase your skills in creating ...

Get the T-shirt to Prove You Survived Splunk University Bootcamp

As if Splunk University, in Las Vegas, in-person, with three days of bootcamps and labs weren’t enough, now ...

Wondering How to Build Resiliency in the Cloud?

IT leaders are choosing Splunk Cloud as an ideal cloud transformation platform to drive business resilience,  ...