Splunk Dev

Python SDK Visualization

leordimalanta
Explorer

Hi to all,

How to produce a visualization in splunk sdk python? For example pie charts, line graph, and etc.

Thanks in advance!

Tags (3)
0 Karma

maurelio79
Communicator

Hi, i'm just learning t as well, anyway you can put your result in xml file, parse the xml and use (for example flotchart) to represent the result. For example:

def get_data(self):


        DATA = []

        params = {"earliest_time" : "-30d", "latest_time" : "now", "exec_mode" : "blocking", "auto_cancel" : 600 }
        search = 'search index=main sourcetype=syslog | search *ERROR* | stats count by process' 
        job = service.jobs.create(search, **params)
        #job = service.jobs.create(search)

        while True: 
          if job.isDone: 
            break 
        content = str(job.results(output_mode='xml'))
        #print "Output: %s" % content

        with open('result.xml', 'w') as f:
            f.write(content)

        tree = ET.parse('result.xml')
        root = tree.getroot()

        for child in root:
            if child[0].tag != "fieldOrder":
                #print child[0][0][0].text, child[1][0][0].text
                DATA.append([child[0][0][0].text, child[1][0][0].text])

        return DATA

Then you have to put the return DATA in flotchart. To know how to use flotchart:
search flotchart on web (it seems i can not insert link)

0 Karma

leordimalanta
Explorer

Thank you! I will try this to my next project!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...