Splunk Cloud Platform

Why can't I access my splunk web running in a centOS VirtualBox

spltov
Explorer

The splunk startup returned the following upon completion.

web - http://livecd.centos:8000
management port - 8089

Tags (1)

DaveSavage
Builder

Try these...if nothing else, it may resolve where you have an issue:
Set the VM network to bridged as opposed to NAT'd
At CLI type ifconfig for your IP address
Ping that IP from a different machine
From the VM - see if you get get outside to the network e.g., and assuming that other security considerations are not an issue...Firefox or browse out to Google.
If this is a test lab or small setup - does your router show any connection as an attached device?
Can you SSH to it using, say PuTTY (although if you can see ping results this is just icing)...but its trying to ascertain whether you can see the virtual host from other machines.
Within that virtual machine, and assuming you have loaded the GUI options of CentOS...try your browser and use the loopback 127.0.0.1:8000
What did you set as VM firewall rules (assuming you are trying to reach Splunk from another machine)...check via GUI System>Administration>Security Level and Firewall. Click on the drop-down and make sure that the required ports have been added...but they should be ok.
Answers to the above will at least narrow the search.
Br
D

DaveSavage
Builder

You are welcome! 😉
I suspect if you can see Splunk via the loopback then you may still have a DNS issue. It may have lost its DNS record. I try to enforce a fixed IP regime which stays persistent through lapses, reboots etc...and then log in to Splunk via http://192.168.0.5:8000 (just change that IP address to whatever your VM instance reported to you on the ifconfig command). Good luck!

0 Karma

spltov
Explorer

DaveSavage, thanks, the loop back was it...

0 Karma

dwaddle
SplunkTrust
SplunkTrust

You've not really given enough information here. What happens when you try? Are you trying from the CentOS machine, or from another machine on the same network? Is the VirtualBox network bridged or NAT?

If this is CentOS, then you should probably check to see if iptables is blocking you. If you aren't familiar, start with a sudo service iptables stop in a terminal on the CentOS machine. See if that helps, if not, you'll need to provide enough information to help make working the problem possible.

username12345lo
New Member

am not the one who ask the question but u ran in to the same issue and your answer saved my life. thank you very much dear.

0 Karma

dwaddle
SplunkTrust
SplunkTrust

Also ... name resolution. I'm doubtful that your Mac (where I assume you are running Safari) has name resolution for the host name livecd.centos .. unless you did something like adding it to /etc/hosts it seems exceedingly unlikely.

0 Karma

MHibbin
Influencer

To make it easier, unless you have a specific reason not to, I would set the network connection to be bridged. This would mean effectively mean that the router just sees another host attached to the network and will assign it an address from you private address range.

spltov
Explorer

I went back & created another vm instance & notice that this time my network interface did not automatically connect. I had to go into VirtualBox Device/Network Adapters and checked cable connected to re-establish the connection. The enable network adapter had been the default with NAT as its value. The cable connection checkbox is an advanced setting. However, when I went back to my host machine (MAC) & attempted to reach http://livecd.centos:8000, I received a "Failed to open page - Safari can't find the server" I am tracking down the iptables.

0 Karma
Get Updates on the Splunk Community!

Running multiple macros in the same search

Hi all!I'm trying to run multiple macros in the same search and eventually aggregate the results from each ...

Logic of Compound Subsearch with inputlookup

I'm struggling to create a search using an inputlookup and multiple NOT searches.Background: I have an ...

Tagging Heavy Forwarders

This is a tip, not a question.&nbsp;<span class="lia-unicode-emoji" ...