Security

web.conf - updateCheckerBaseURL

Path Finder

Hi @ All,

i create a little app to set "updateCheckerBaseURL" value to "0".
Then i copied it to "/opt/splunk/etc/deployment-apps" on Deployment Server and changed folder permissions to the splunk user.

The app where deployed to the clients and "./splunk cmd btool web list settings" displays "updateCheckerBaseURL = 0", but the update notification where still there.

If i set "updateCheckerBaseURL = 0" direct to "$SPLUNK_HOME/etc/system/local/web.conf", then the update notification where disabled.

Please advise - Markus

0 Karma
1 Solution

Influencer

I am using below attributes under [settings] stanza in web.conf in an app and it works fine.

[settings]    
# Disable Splunk automatic checking for new app versions
updateCheckerBaseURL = 0

You may need to provide read permissions to the app in metadata. Create a metadata directory in your app and create default.meta in it with below content.

[]
access = read : [ * ], write : [ admin ]
export = system

View solution in original post

Influencer

I am using below attributes under [settings] stanza in web.conf in an app and it works fine.

[settings]    
# Disable Splunk automatic checking for new app versions
updateCheckerBaseURL = 0

You may need to provide read permissions to the app in metadata. Create a metadata directory in your app and create default.meta in it with below content.

[]
access = read : [ * ], write : [ admin ]
export = system

View solution in original post