Security
Highlighted

"acceptFrom" option in web.conf doesn't work

Explorer

Hi

Could you help me with "web.conf"?

I would like to accept or block users to access to web interface with IP address.

So I found "acceptFrom" option and applied to /system/local/web.conf

But when I tried to restart Splunk, I got this error: "WARNING: web interface does not seem to be available!"

splunkd log shows

02-07-2019 17:35:51.968 +0900 WARN HTTPServer - Refusing HTTP connection from 127.0.0.1 due to server ACL
02-07-2019 17:35:52.069 +0900 WARN HTTPServer - Refusing HTTP connection from 127.0.0.1 due to server ACL
02-07-2019 17:35:52.085 +0900 WARN HTTPServer - Refusing HTTP connection from "my local IP" due to server ACL

02-07-2019 17:35:52.093 +0900 WARN HTTPServer - Refusing HTTP connection from "my local IP" due to server ACL

And my web.conf settings are like this

[settings]

acceptFrom = "my local IP"

Thanks for reading this.

0 Karma
Highlighted

Re: "acceptFrom" option in web.conf doesn't work

SplunkTrust
SplunkTrust

What about if you do acceptFrom = 127.0.0.1,my local IP

View solution in original post

0 Karma
Highlighted

Re: "acceptFrom" option in web.conf doesn't work

Explorer

Thank you for your answer. But i already tried and got the same result.

0 Karma
Highlighted

Re: "acceptFrom" option in web.conf doesn't work

Explorer

It took me a whole day to figure out, but I took out the quotation mark and it worked. And must include "127.0.0.1". Thank you so much for your help @chrisyoungerjds

0 Karma