Security

Why can I not login with a default password for web interface in Splunk 7.1.1 enterprise?

Path Finder

imigae : splunk-7.1.1-8f0ead9ec3db-Linux-x86_64.tgz
installation: tar xvzf splunk-7.1.1-8f0ead9ec3db-Linux-x86_64.tgz
path: /opt/splunk

CLI authentication is successful (see following). But use the same username and password can not login the web interface. If I remove $SPLUNK_HOME/etc/passwd to "passwd.bak" and restart splunk, when I try to login with "admin" it will say "No users exist. Please set up a user. "

splunk list monitor

Your session is invalid.  Please login.
Splunk username: admin
Password:
Monitored Directories:
        $SPLUNK_HOME/var/log/introspection
                /opt/splunk/var/log/introspection/disk_objects.log
                /opt/splunk/var/log/introspection/http_event_collector_metrics.log
                /opt/splunk/var/log/introspection/kvstore.log
                /opt/splunk/var/log/introspection/resource_usage.log
        $SPLUNK_HOME/var/log/splunk
                /opt/splunk/var/log/splunk/audit.log
                /opt/splunk/var/log/splunk/btool.log
                /opt/splunk/var/log/splunk/conf.log
                /opt/splunk/var/log/splunk/django_access.log
                /opt/splunk/var/log/splunk/django_error.log
                /opt/splunk/var/log/splunk/django_service.log
                /opt/splunk/var/log/splunk/export_metrics.log
                /opt/splunk/var/log/splunk/first_install.log
                /opt/splunk/var/log/splunk/health.log
                /opt/splunk/var/log/splunk/license_usage.log
                /opt/splunk/var/log/splunk/metrics.log
                /opt/splunk/var/log/splunk/mongod.log
                /opt/splunk/var/log/splunk/remote_searches.log
                /opt/splunk/var/log/splunk/scheduler.log
                /opt/splunk/var/log/splunk/searchhistory.log
                /opt/splunk/var/log/splunk/splunkd-utility.log
                /opt/splunk/var/log/splunk/splunkd.log
                /opt/splunk/var/log/splunk/splunkd_access.log
                /opt/splunk/var/log/splunk/splunkd_stderr.log
                /opt/splunk/var/log/splunk/splunkd_stdout.log
                /opt/splunk/var/log/splunk/splunkd_ui_access.log
                /opt/splunk/var/log/splunk/web_access.log
                /opt/splunk/var/log/splunk/web_service.log
        $SPLUNK_HOME/var/log/splunk/license_usage_summary.log
                /opt/splunk/var/log/splunk/license_usage_summary.log
        $SPLUNK_HOME/var/spool/splunk/...stash_new
Monitored Files:
        $SPLUNK_HOME/etc/splunk.version

0 Karma
1 Solution

Path Finder

Shit, it's the Firefox problem. I'm using Firefox 61.0.1 (64-bit), looks like compatible issue. I switch to Chrome and login successfully!!!

Hope you guys can repeat this bug with the same version of Firefox.

0 Karma

Contributor

Hi Haoban,

you will have to set uname and password prior installation, please check the doc below.

https://docs.splunk.com/Documentation/Splunk/7.1.1/Installation/StartSplunkforthefirsttime

Let me know if this helps.

0 Karma

Path Finder

It doesn't work, I did it before but set the password as "changeme" and this time I set the password by using random characters. Same issue. CLI authentication successful but web interface failed.
Strong password policy issue? password length? special characters? any limits? My random password has 10 characters and contains upper-case and lower-case letters, numerical digits and special characters.

0 Karma