Security

Why LDAP authentication issue after upgrading from 7.3.5 to 8.1.0?

secengineering
Engager

Hello all, after upgrading splunk to 8.1.0 , we have observed some issues with LDAP authentication. The uers are not able to login for sometime and after 10-15 mins the credentials work. Once we disabled ldap authentication on couple of servers, nowits working. We dont see any error/ warnings related to LDAP in splunk. Can someone please help and let em know if there is any known issue in this.

THanks

Labels (2)
Tags (2)
0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

how many users you have in LDAP which match your ldap search? There are some limits for default count of users returned by LDAP queries? 

https://community.splunk.com/t5/Security/How-to-load-more-than-1000-records-from-LDAP/m-p/37393

With 8.1.7.2 we have issues that users are found from LDAP server, but don't in Splunk->User mapping. With debug it shows that splunk found those correctly, but didn't add those to this list (in GUI) also some roles didn't work for that reason, even those are found on authorisation phase.

r. Ismo

0 Karma
Get Updates on the Splunk Community!

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...