Security
Highlighted

Unable to connect to the splunk web interface

Path Finder

I have been using the splunk web interface with this address 127.0.0.1:8000 for almost two months now, but all of the sudden it just stopped connecting and it's giving me a message saying that "Firefox can't establish a connection to the server at 127.0.0.1:8000".

please help i don't know what went wrong.

Highlighted

Re: Unable to connect to the splunk web interface

Communicator

is splunk running?

what OS are you on?

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Path Finder

hi n00badmin

i am using centos and splunk is running

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

SplunkTrust
SplunkTrust

Assuming Splunk is running, someone may have changed the port or HTTPS encryption.

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Splunk Employee
Splunk Employee

Try restarting your instance of splunk : 'sudo /opt/splunk/bin/splunk restart'. Check the message when it restarts and confirm what IP and port Splunk is bound to. (It will say started on http://localhost:8000 or https://localhost:XXXX"

Check if iptables has been started or running : service iptables status service iptables stop

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Path Finder

hi esix_splunk

The iptables seems ok but when i run the command 'sudo /opt/splunk/bin/splunk restart' i don't get any response.

i get this:

[root@...]# sudo /opt/splunk/bin/splunk restart
[root@..]#

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Hi cebo_myeza,

  • Try to check if the attribute startwebserver of web.conf file is set to 1.

    web.conf is located to $SPLUNK_HOME/etc/system/default/

  • Or try to run individualy the command that follow:

    sudo /opt/splunk/bin/splunkd start and sudo /opt/splunk/bin/splunkweb start

Highlighted

Re: Unable to connect to the splunk web interface

Path Finder

if i check the attributes of startwebserver everything seems okay here is the copy below:

[settings]

enable/disable the appserver

startwebserver = 1

httpport = 8000

enableSplunkWebSSL = false

mgmtHostPort = 127.0.0.1:8089

appServerPorts = 8065

And if i run the command 'sudo /opt/splunk/bin/splunkd start' i get the following error

[root@localhost wisdom.network_trainee]# sudo /opt/splunk/bin/splunkweb start
sudo: /opt/splunk/bin/splunkweb: command not found

[root@localhost wisdom.network_trainee]# sudo /opt/splunk/bin/splunkd start
/opt/splunk/bin/splunkd: error while loading shared libraries: libjemalloc.so.1: cannot open shared object file: No such file or directory

thanks for your time ngatchasandra

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Communicator

dude,

you need to locate your install...

does /opt/splunk/bin exist?

if it does do:

cd /opt/splunk/bin
./splunk stop

what do you get???

0 Karma
Highlighted

Re: Unable to connect to the splunk web interface

Path Finder

i still don't get any response like this:

[root@localhost wisdom.network_trainee]# cd /opt/splunk/bin
[root@localhost bin]# ./splunk stop
[root@localhost bin]# ./splunk start
[root@localhost bin]#

0 Karma