Security

SSO SAML using ADFS

pl2345
Path Finder

I've tried for the past few days using every article and resource I can to get Splunk to work with SSO, but am ending up short.
We currently have an instance installed on a windows server that works fine with ADFS. I took over this position and they wanted a separate instance installed on a Linux box and to use ADFS as well. I'm using version 7.3.1 and the current errors in my splunkd.log file are errors in the XMLParser and SAML involving the func=xmlSecOpenSSLAppKeyLoadBIO and failed to load private pem key.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...