Security

Manager view for power user does not list any options even if i have given the power user the necessary capabilities.

Splunk Employee
Splunk Employee

So, a case came in with the following issue:
"Even after giving the power user (read role) the capability to edit_monitor list_inputs etc, i still do not see the listing for Data Inputs on the right hand side menu in the manager view"

I thought the customer might have done something wrong with his configs but found out that the same was happening for me. And so started an epic war against the UI to try and find out what capabilities i needed to add to a role so that users that belonged to it would be able to see more then just the "User Options" on the right hand side menu of the Manager View.

It turns out that no matter what capabilities you add, the other options do not show up. So, what do i need to do in order to have the "Data Inputs" (for example) show up for the poweruser?

Tags (4)
1 Solution

Splunk Employee
Splunk Employee

Ambushing one of the UI dev's and torturing him for a while i found out what one needs to do in order to have specific portions, or all, of the right hand side menu in the manager view show up.

Browse to:

/splunk/etc/apps/search/metadata/ 

and create/edit the local.meta file to contain the following:

[manager/datainputstats] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_monitor] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_script] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_tcp_cooked] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_tcp_raw] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_udp] 
access = read : [ power ], write : [ admin ] 

Restart Splunk and login as a poweruser. You should now see "Data Inputs" on the right hand side menu, along side the "User Options" - which always shows..

Note, with this config powerusers will only be able to see/list the data inputs and not change the config. If this is what is wanted then change the write: [admin] to [power] and you should be done.

This is not really documented and i hope this answers page might help others out there...
cheerio!
.gz

View solution in original post

Splunk Employee
Splunk Employee

Ambushing one of the UI dev's and torturing him for a while i found out what one needs to do in order to have specific portions, or all, of the right hand side menu in the manager view show up.

Browse to:

/splunk/etc/apps/search/metadata/ 

and create/edit the local.meta file to contain the following:

[manager/datainputstats] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_monitor] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_script] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_tcp_cooked] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_tcp_raw] 
access = read : [ power ], write : [ admin ] 

[manager/data_inputs_udp] 
access = read : [ power ], write : [ admin ] 

Restart Splunk and login as a poweruser. You should now see "Data Inputs" on the right hand side menu, along side the "User Options" - which always shows..

Note, with this config powerusers will only be able to see/list the data inputs and not change the config. If this is what is wanted then change the write: [admin] to [power] and you should be done.

This is not really documented and i hope this answers page might help others out there...
cheerio!
.gz

View solution in original post