Security

Is there a recent change in Splunk that caused the proxy settings in server.conf to change?

Volto
Path Finder

Hello,

I was wondering if there was a recent change in Splunk that caused the proxy settings in server.conf to change.

We've recently installed a fresh version of Splunk 7.0.2, and we noticed a large amount of proxy requests for the localhost of the Splunk box over the internal Splunk port of 8089.

Looking through the docs; http://docs.splunk.com/Documentation/Splunk/7.0.2/Admin/Serverconf#Splunkd_http_proxy_configuration, it says that the no_proxy configuration is set to localhost and 127.0.0.1 by default.

Looking through the default server.conf on our installation I don't see the no_proxy setting set.

Has anyone else seen this behavior with their Splunk installation?

Volto
Path Finder

After setting the no_proxy setting in server.conf Splunk looks like it's still attempting to use the proxy to connect to localhost.

Looking in the documentation it has the addresses wrapped in double quotes, is that needed for the no_proxy setting?

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...