Security

How to configure exceptions to proxy config in splunk-launch.conf?

flle
Path Finder

Hi,

to support several external lookups to internet services with APIs I added a proxy configuration to splunk-launch.conf:
HTTP_PROXY=proxy.example.net:8080
HTTPS_PROXY=proxy.example.net:8080

Now I have an external lookup to an API on my internal network which should connect directly but not via the proxy.
Forwarding the connection from the proxy to the internal network is not possible, so I need a solution on the Splunk Search Head.

Question:
Is it somehow possible to configure exceptions which should not go via the proxy configured in splunk-launch.conf?

Thanks & regards

0 Karma

ejwade
Contributor

I couldn't get it to work with wild cards or CIDR notation, but I did get it to work with the following:

no_proxy = fqdn.localdomain, 10.0.0.1, localhost, 127.0.0.1, ::1

The key is no quotes, and IPs/FQDNs fully spelled out.

micahkemp
Champion

I’ve seen the same behavior. Wildcards don’t appear to work, but lists do.

vliggio
Communicator

Something like this:

NO_PROXY = *.domain.com,10.0.0.0/8,localhost,127.0.0.1,::1

You can set this either in your environment variables or in splunk-launch.conf. Either will work.

itradeclayton
Path Finder

yes, there is a "no_proxy" setting, however the syntax is unclear... I'm also trying to find this out.

0 Karma
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...