How to change permission

New Member

I created a dashboard and added lookup tables, they are private. and I'm not seeing any options to change permission. please let me know how can I do this.


Tags (1)
0 Karma


Settings > Lookups > Lookup definitions > Select Permission in front of your lookup

Settings > User Interface > Views > Select Permission in front of your dashboard


  • User: Only you can see it.
  • This App only: You can access this from this App only.
  • All Apps: From all app it can be accessed.
0 Karma


If you want to change permissions of lookups you should go to Settings -> Lookups -> Lookup Table Files. You will see a list of all your lookup table files. There is a tab named "Sharing" that will show the permissions for each lookup, and when you click at "Permissions" button you will be able to see the permissions menu.

If you wanna change permissions of a dashboard you can go to "Dashboards". You will see a list of your dashboards. Click Edit -> Edit Permissions.

Also, you should check if the role you are using has the permission to change permissions of all objects in Splunk.

0 Karma

New Member

Please find the below snippet. I'm not able to see the permission options. My lookup table is Domain_Data and there is no permission option shown here.

/usr/splunk0/splunk/etc/users/adcgrhh/bnym_fxr_srv/lookups/Domain_Data.csv adcgrhh bnym_fxr_srv Private Enabled Move | Delete

/usr/splunk0/splunk/etc/apps/search/lookups/GlobalExclusionList.csv xbbl6f9 Global | Permissions Enabled

0 Karma


Can you tell what role you are in? Does It have the capability to change permissions?

As the lookup is Private, if you are not the creator of this lookup, you will have to be an admin to change permissions for this object.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!