Security

How can I disable the login notification message that a new Splunk version is available?

Splunk Employee
Splunk Employee

My Splunk users do not need to know when a new version of Splunk is available and would like to remove this messaging. As the Splunk Administrator I access Splunk.com sufficiently to see when a new release is available. How can I turn this notification off?

Tags (2)
1 Solution

Splunk Employee
Splunk Employee

web.conf contains the setting from which you can disable Splunk automatic checking for new versions:

By default the setting is:

updateCheckerBaseURL = http://quickdraw.splunk.com/js/ 

To disable automatic checking, add to your $SPLUNK_HOME/etc/system/local/web.conf:

[settings]
updateCheckerBaseURL = 0

Note: Disabling this feature will apply to all Splunk non-admin and admin users.

For further information refer to:

http://www.splunk.com/base/Documentation/4.0.11/Admin/Webconf or a related topic on suppressing messages for non-admin users.

View solution in original post

Path Finder

For the free version of Splunk the webconf is located here.
$SPLUNK_HOME/etc/system/local/web.conf

The setting below is the same.
[settings]
modify this updateCheckerBaseURL = http://quickdraw.splunk.com/js/

to
updateCheckerBaseURL = 0

If this file does not exist just create a file called "web.conf" in the directory $SPLUNK_HOME/etc/system/local/web.conf
Thanks for the correction to edit local (not default files).
This is because when splunk upgreades the default files are overwritten.
=)

Path Finder

Please do not change files in the system/default location. use system/local instead.

Splunk Employee
Splunk Employee

web.conf contains the setting from which you can disable Splunk automatic checking for new versions:

By default the setting is:

updateCheckerBaseURL = http://quickdraw.splunk.com/js/ 

To disable automatic checking, add to your $SPLUNK_HOME/etc/system/local/web.conf:

[settings]
updateCheckerBaseURL = 0

Note: Disabling this feature will apply to all Splunk non-admin and admin users.

For further information refer to:

http://www.splunk.com/base/Documentation/4.0.11/Admin/Webconf or a related topic on suppressing messages for non-admin users.

View solution in original post

Engager

Is there any reason for this not to work? I copied the default folder web.conf into local. I then set updateCheckerBaseURL = 0 & restarted the machine. But I'm still getting prompted to update.

Path Finder

Actually I think I figured out, looks to be a browser cache issue, I hopped on another machine and they are indeed fixed, woohoo.

0 Karma

Path Finder

I'm seeing the same thing, only on SHC members though after doing a rolling-restart. The rest of my infrastructure this worked fine.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!