Security

Creating new CSR unable to find shared library libssl.so.0.9.8

jason_hubbard
Path Finder

I am try to generate a CSR on CentOS 6 based on the Splunk admin documentation for "Generate a CSR". I used the following command:
Command
$SPLUNK_HOME/bin/openssl req -newkey rsa:2048 -key [certificate name].pem -out [certificate name].csr
Result
$SPLUNK_HOME/bin/openssl: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

The $SPLUNK_HOME/lib/ shows the following in the directory ...
lrwxrwxrwx 1 splunk splunk 15 Sep 29 10:53 libssl.so -> libssl.so.0.9.8
-r-xr-xr-x 1 splunk splunk 324464 Sep 8 15:54 libssl.so.0.9.8

ashrafmr
Engager

If you do not use Splunk's own packaged libraries then you will have circumvented the defects and security fixes that have been addressed with Splunk's use of those dependent libraries, i.e. those identified in the Splunk release notes.

  • I would add the Splunk library path, /opt/splunk/lib, as one line into a text file (such as spunk.conf) and place that file in the /etc/ld.so.conf.d directory.

  • Then with root privilege run ldconfig.

You should then be able to use Splunks own bundled OpenSSL at /opt/splunk/bin/openssl

ifnadmin
Engager

Still works 6 years later.  Thank you!

~T

0 Karma

JohnK08345
Engager

You can also just export LD_LIBRARY_PATH=/opt/splunk/lib, if you don't want mess with getting root access.

reswob4
Builder

This worked for me. @ashrafmr, you should accept this answer.

0 Karma

dsharp1970
Engager

Worked great for me. Thanks!

0 Karma

rossikwan
Path Finder

try using the openssl located in /usr/bin or type the absolute path as below

/usr/bin/openssl genrsa -des3 -out mySplunkWebPrivateKey.key 2048

0 Karma
Get Updates on the Splunk Community!

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...