Security

Cannot re-add UDP data input after deleting it. Parameter name: UDP port 514 is not available

peter_dmitrieff
New Member

First I wanted to create an alternate data input using 514/udp, so I disabled the existing one and tried to clone another one, and change the port number. Got rejected with the full text message: "Encountered the following error while trying to save: Parameter name: UDP port 514 not available."

I deleted the existing one and tried again. No joy. Tried setting up new data input, still can't.

Recycling Splunk didn't help. I'm now stuck with a system with no 514/UDP listener, and no way to even add back the original one, because it somehow thinks it's still in use.

Any suggestions on how to clear it out the vestigial information preventing me from adding anything on the old port?

0 Karma

a_salikov
Path Finder

Hello Peter,

could you resolve your problem?
If yes, can you say how you solve it? Thanks!

Best regards, Ablay.

0 Karma

peter_dmitrieff
New Member

Going to answer my own question: pilot error.

There was an unrelated syslog listener on the box (Windows) that grabbed hold of the port.

Killed that off to release the port for Splunk to use.

0 Karma
Get Updates on the Splunk Community!

Announcing General Availability of Splunk Incident Intelligence!

Digital transformation is real! Across industries, companies big and small are going through rapid digital ...

Splunk Training for All: Meet Aspiring Cybersecurity Analyst, Marc Alicea

Splunk Education believes in the value of training and certification in today’s rapidly-changing data-driven ...

The Splunk Success Framework: Your Guide to Successful Splunk Implementations

Splunk Lantern is a customer success center that provides advice from Splunk experts on valuable data ...