Security

After PAM scripted authentication we get admin:1661 - 'str' object has no attribute 'os_startIndex' error

langhorn
Explorer

Hi

We have just switched from native Splunk authentication to PAM scripted authentication.
We are running Splunk 6.3.4 under Linux Suse, sles 11.

After switching to PAM scripted authentication the administrator can no longer see the list of users in the GUI (under Settings/Access Controls/Users).
Instead we get an error page and we can see internal error is related to
"admin:1661 - 'str' object has no attribute 'os_startIndex'"
Traceback (most recent call last): File "/opt/splunk/lib/python2.7/site-packages/splunk/appserver/mrsparkle/controllers/admin.py", line 1656, in listEntities pwnrList = en.getEntities("authentication/users", count=250, search="roles=*") File "/opt/splunk/lib/python2.7/site-packages/splunk/entity.py", line 131, in getEntities

It seems to indicate a limit of 250 users but we do not have anything like 250 users in the system, which seems to be a (arbitrary) limit set in admin.py. We have tried to increase the count but it did no help.

The PAM authentication is actually working but it is a major problem not to be able to see the list of users or to delete the old native user ids in the GUI.

We tried to switch back to native authentication and there is no problem displaying the old users again.

Thanks for any suggestions to resolve this issue.

0 Karma
1 Solution

langhorn
Explorer

Well, found the answer myself in the end.
It turned out to be a problem in /etc/passwd, where a user had a strange character in the description field.

View solution in original post

0 Karma

langhorn
Explorer

Well, found the answer myself in the end.
It turned out to be a problem in /etc/passwd, where a user had a strange character in the description field.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...