Reporting

In GUI, I cannot see email settings, which was deployed by Deployment Server, in the GUI

Splunk Employee
Splunk Employee

I deployed alert_actions.conf to a search head through a Deployment Server.
The email alert works. But I cannot see the setting in the WebGUI. It shows no settings.

In splunkd.log, there is no error or warning message.
A btool output shows the correct email settings.

Why can I see the settings through GUI?
How I can make it available through GUI, too?

0 Karma
1 Solution

Splunk Employee
Splunk Employee

It is related to a permission for an App which was deployed by a deployment server.

Usually you do not encounter this situation because Splunk Web can still shows each apps configuration per app.

But, "email" setting must be "global". So, you need local.meta to set "export = system".

- local.meta
[]
# This stanza is to make all the app's configuration to "global"
export = system

Or, if it's only for email.

- local.meta
[alert_actions/email]
export = system
owner = nobody

View solution in original post

Champion

could u tell me how did u configured email settings?

————————————
If this helps, give a like below.
0 Karma

Splunk Employee
Splunk Employee

It is related to a permission for an App which was deployed by a deployment server.

Usually you do not encounter this situation because Splunk Web can still shows each apps configuration per app.

But, "email" setting must be "global". So, you need local.meta to set "export = system".

- local.meta
[]
# This stanza is to make all the app's configuration to "global"
export = system

Or, if it's only for email.

- local.meta
[alert_actions/email]
export = system
owner = nobody

View solution in original post