Reporting
Highlighted

Alerts aren't sending emails: error - "501, 'Syntactically invalid HELO argument(s)') while sending mail to"

Explorer

I have created an alert in Splunk which when triggered sends an email to a specified mail id. But sadly, the mail is not getting sent. I checked the python.log file to find this:

501, 'Syntactically invalid HELO argument(s)') while sending mail to

Has anyone encountered this before? What could the reason for this issue? Any fixes?

Thanks

0 Karma
Highlighted

Re: Alerts aren't sending emails: error - "501, 'Syntactically invalid HELO argument(s)') while sending mail to"

Legend

Hi
there could be a communication problem in the SMTP level, during the ehlo/helo command exchange.
It can be caused by many reasons:

  • Firewall;
  • Authentication issue;
  • Hostname of the machine is different to what the mailserver expects;
  • Underscore(_) in the host name (underscore character is not a permitted character for the hostname).

Verify if the mail service is running scheduling a simple report.
Bye.
Giuseppe

View solution in original post

0 Karma
Highlighted

Re: Alerts aren't sending emails: error - "501, 'Syntactically invalid HELO argument(s)') while sending mail to"

Explorer

What is this error all about, any idea sir?

sendemail:452 - [SSL: WRONGVERSIONNUMBER] wrong version number (_ssl.c:676) while sending mail to

Highlighted

Re: Alerts aren't sending emails: error - "501, 'Syntactically invalid HELO argument(s)') while sending mail to"

Path Finder

I am also getting same error ,could you please tell me the solution

0 Karma