Monitoring Splunk

splunkd.log Error: OPENSSL_1.0.0 not found (required by wget)

Receiving the following error message in S.o.S. Splunk in the splunkd.log:

12-28-2013 16:32:28.175 -0500 ERROR ExecProcessor - message from "/opt/splunk/bin/scripts/fetch.sh" wget: /opt/splunk/lib/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by wget)

I have seen these two posts but they do not give instructions on exactly how to change LD_LIBRARY_PATH for Splunk:

http://answers.splunk.com/answers/105439/no-port_scan-data

http://answers.splunk.com/answers/106816/commands-broken-after-upgrade-to-splunk-6

Any instruction on the exact procedure of changing LD_LIBRARY_PATH for Splunk in this situation would be highly appreciated. Thank you!

0 Karma
1 Solution

Path Finder

Add the following to the first line of your fetch.sh script, then save, and restart Splunk then review S.o.S. error messages:

unset LD_LIBRARY_PATH

View solution in original post

Path Finder

Add the following to the first line of your fetch.sh script, then save, and restart Splunk then review S.o.S. error messages:

unset LD_LIBRARY_PATH

View solution in original post

Engager

FWIW: if you're encountering this error in python, adding the following worked for me:

import os
os.unsetenv('LD_LIBRARY_PATH')

thanks for the answer.

0 Karma

Thanks that was all that was required. After adding line to script and restarting error was corrected.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!