Knowledge Management

Missing permissions in data model

New Member

My Splunk instance is missing the full permissions options when attempting to edit permissions on a data model. In my case, all I see when I do Edit > Edit Permissions is:
Data Model: Name
Owner: admin
App: appname
Display For: Owner | App | All Apps.

But I do not get the checkboxes when selecting among Owner, App, All apps.

This is on a dev/test system with a new Ubuntu Install, fresh Splunk 6.5.2, and only one source feeding it data via syslog.

Is there anything I need to do to get the additional permissions options to display?

0 Karma

New Member

Hey @cmerriman,

Yes, in both instances I am using an admin-level account. In the test instance with the fresh install, the default 'admin' account is the only account in splunk. I can create and edit everything about the data model, and even move the permissions between the three options (app, all apps, etc) but I cannot view the granular permissions with the checkboxes.

0 Karma

Super Champion

what type of role are you? Admin or Power?
I believe only Admin or Power users can edit permissions on KOs.
http://docs.splunk.com/Documentation/SplunkCloud/6.5.1612/Knowledge/Manageknowledgeobjectpermissions...

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!