Knowledge Management

Can the _introspection index use SmartStore?

esalesapns2
Path Finder

I created a fresh index cluster in AWS using the Splunk AMI, upgraded to 7.2.5.1.

In the "Configure SmartStore" doc, Splunk says, "The following indexes.conf settings must remain unset: bloomHomePath sumaryHomePath tstatsHomePath."

To try to enforce this on all indexes, in my master node, I created indexes.conf in etc/master-apps/_cluster/local and put in:

bloomHomePath =
summaryHomePath =
tstatsHomePath =

When I run "splunk validate cluster-bundle" I don't get an error, but when I then run "splunk show cluster-bundle-status" it says,

[Critical] stanza=_introspection Required parameter=tstatsHomePath not configured

Unless I remove the tstatsHomePath setting, the bundle won't validate.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.