splunk enable boot-start not working SLES 15.1

New Member

Trying to enable startup on SLES 15.1:

/opt/splunkforwarder/bin # ./splunk enable boot-start
Unknown option: levels
chkconfig -A|--allservices (together with -l: show all services)
chkconfig -t|--terse [names] (shows the links)
chkconfig -e|--edit [names] (configure services)
chkconfig -s|--set [name state]... (configure services)
chkconfig -l|--list [--deps] [names] (shows the links)
chkconfig -L|--liston [--deps] [names] (as -l, enabled in at least 1 level)
chkconfig -c|--check name [state] (check state)
chkconfig -a|--add [names] (runs insserv)
chkconfig -d|--del [names] (runs insserv -r)
chkconfig -h|--help (print usage)
chkconfig -f|--force ... (call insserv with -f)chkconfig [name] same as chkconfig -t
chkconfig name state... same as chkconfig -s name state
chkconfig --root=<root> ... use <root> as the root file system

Labels (1)
0 Karma


Try specifying systemd and be sure to use sudo or run as root user:

sudo /opt/splunk/bin/splunk enable boot-start -user splunk -systemd-managed 1

An upvote would be appreciated and Accept Solution if it helps!
0 Karma
Get Updates on the Splunk Community!

Dashboard Studio Challenge - Learn New Tricks, Showcase Your Skills, and Win Prizes!

Reimagine what you can do with your dashboards. Dashboard Studio is Splunk’s newest dashboard builder to ...

Introducing Edge Processor: Next Gen Data Transformation

We get it - not only can it take a lot of time, money and resources to get data into Splunk, but it also takes ...

Take the 2021 Splunk Career Survey for $50 in Amazon Cash

Help us learn about how Splunk has impacted your career by taking the 2021 Splunk Career Survey. Last year’s ...