Installation

expose splunk thru k8s ingress

New Member

Hello:

Here's the tech stacks i am using :

  1. AWS EKS 1.16
  2. Deployed docker based yaml "splunk/splunk:latest" to EKS using default - "SPLUNK_START_ARGS=--accept-license" as well as SPLUNK_PASSWORD provided.

I used statefulset and service, with service (loadbalancer enabled), i am able to directly access it from my laptop, however with ingress enabled, it is not happening. Even I created route53 pointing to service (load balancer AWS), still not able to access.

I also created "hello world" (contianing statefulset, service and ingress), i am able to open,. Kindly let me know if anything is to be corrected when using ingress ?

Labels (1)
Tags (1)
0 Karma