Why am I unable to upload a custom app in Splunk with error "No such file or directory"?


I am getting the following error when uploading a custom app, but the other custom apps work fine.
I have tried via the UI and the CLI, same error in the log

11-24-2015 03:48:59.646 +0000 ERROR LocalAppsAdminHandler - Error during app install: failed to copy /opt/splunk/var/run/9c872453d1076432/tasman to /opt/splunk/etc/apps/tasman: No such file or directory

I have checked and played with permissions, same result.
I have created the tasman.tgz app archive file in Windows and Linux, same error.
I have tried renaming it to tasman.spl, same error.
I can't find this anywhere /opt/splunk/var/run/9c872453d1076432/tasman
and /opt/splunk/etc/apps/tasman is a dir on the Splunk server with the correct permissions.

Any ideas?


Labels (2)
0 Karma


Try to do it manually. decompress The app, copy his folder and paste it in /opt/splunk/etc/apps/
After, restart splunk server.

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!


Or Learn More in Our Blog >>