LOgin problem on new installation

New Member

I installed splunk on Centos 7 and have it running with the systemctl commands.
On my first login I got an error when I tried to change the password.
So now it gets back to the login page if I use the changeme password. Any other password gives me a password error.
I tried the suggested removal of the splunk password file to see if I could get back to the changeme procedure but it did not resolve the issue.

What information can I look into to resolve the issue?

Tags (1)
0 Karma

Esteemed Legend

Do this:

splunk stop # does not require password
mv /opt/splunk*/etc/passwd /opt/splunk*/etc/passwd.bak # NOTE: also removes all other splunk users
splunk start # does not require password; the admin user is recreated and the password will be `changeme`
0 Karma


Try this from command line:

$SPLUNK_HOME/bin/splunk edit user admin -password "apassword"

Replace $SPLUNK_HOME with the path to splunk if $SPLUNK_HOME is not defined in your environment.

Then you should be able to log as admin and the password you gave in the command.

See this for other examples:

Maybe you can add a new admin user and then edit the old via GUI if you want...

0 Karma
Get Updates on the Splunk Community!

Infographic provides the TL;DR for the 2023 Splunk Career Impact Report

We’ve been shouting it from the rooftops! The findings from the 2023 Splunk Career Impact Report showing that ...

Splunk Lantern | Getting Started with Edge Processor, Machine Learning Toolkit ...

Splunk Lantern is Splunk’s customer success center that provides advice from Splunk experts on valuable data ...

Enterprise Security Content Update (ESCU) | New Releases

In the last month, the Splunk Threat Research Team (STRT) has had 2 releases of new security content via the ...