Installation

How to resolve proxy error after upgrading from 6.1 to 6.21.?

vasanthmss
Motivator

Hi splunkers,

Before upgrade there was no such errors,. From 6.1 to 6.2.1 upgrade I am getting the following error,

Here is the error I'm getting in the browser,

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /en-US/app/<app_name>/search.

Reason: Error reading from remote server

Apache/2.2.26 (Amazon) Server at <domain_name> Port 443
V
Labels (1)
Tags (4)
1 Solution

vasanthmss
Motivator

workaround of the issue to set appServerPorts=0 in web.conf

check the web.conf

FYI,

appServerPorts = <one or more port numbers>
        * Port number(s) for the python-based application server to listen on.
          This port is bound only on the loopback interface -- it is not
          exposed to the network at large.
        * If set to "0", this will prevent the application server from
          being run from splunkd.  Instead, splunkweb will be started as
          a separate python-based service which directly listens to the
          'httpport'.  This is how Splunk 6.1.X and earlier behaved.
        * Generally, you should only set one port number here.  For most
          deployments a single application server won't be a performance
          bottleneck.  However you can provide a comma-separated list of
          port numbers here and splunkd will start a load-balanced
          application server on each one.
        * It is recommended that this be set to a non-zero value.  Setting
          this to "0" should only be done if you experience a compatibility
          problem.  The new separate application server configuration is faster
          and supports more configuration options.  Also, setting this to
          "0" may cause problems when using the Search Head Clustering feature
          (see the [shclustering] stanza in server.conf)
        * Defaults to 8065.
V

View solution in original post

vasanthmss
Motivator

workaround of the issue to set appServerPorts=0 in web.conf

check the web.conf

FYI,

appServerPorts = <one or more port numbers>
        * Port number(s) for the python-based application server to listen on.
          This port is bound only on the loopback interface -- it is not
          exposed to the network at large.
        * If set to "0", this will prevent the application server from
          being run from splunkd.  Instead, splunkweb will be started as
          a separate python-based service which directly listens to the
          'httpport'.  This is how Splunk 6.1.X and earlier behaved.
        * Generally, you should only set one port number here.  For most
          deployments a single application server won't be a performance
          bottleneck.  However you can provide a comma-separated list of
          port numbers here and splunkd will start a load-balanced
          application server on each one.
        * It is recommended that this be set to a non-zero value.  Setting
          this to "0" should only be done if you experience a compatibility
          problem.  The new separate application server configuration is faster
          and supports more configuration options.  Also, setting this to
          "0" may cause problems when using the Search Head Clustering feature
          (see the [shclustering] stanza in server.conf)
        * Defaults to 8065.
V
Get Updates on the Splunk Community!

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...

Stay Connected: Your Guide to April Tech Talks, Office Hours, and Webinars!

Take a look below to explore our upcoming Community Office Hours, Tech Talks, and Webinars in April. This post ...