Getting Data In

how to filter and forward to multiple destination

Path Finder


I tried this configuration but it ended up badly, there were no more log on Splunk:

TRANSFORMS-host = paloalto_hostoverride
TRANSFORMS-routing = IndexersRouting, Routing-PA-filterhost

SOURCE_KEY = MetaData:Host
FORMAT= Routing-PA

FORMAT= indexersRouting

I also tried to reverse the TRANSFORMS-routing order and there was less logs than usual.
the regex works and the inputs.conf I have set

  connection_host = none

Is it possible that my transform-host is not applied before my transform-routing so that the SOURCE_KEY = MetaData:Host is useless?
Or do I need to set a specific order in the Transform-routing??

back to the original config which actually works:

TRANSFORMS-routing = Routing-PA

FORMAT= Routing-PA, indexersRouting
0 Karma

Path Finder


sorry but I don't get it, you're probably right about field overriding but how can I avoid it??
my goal is to forward all the logs to my indexers and all except a specific host to an external log collector.

I already have 2 different tcpout groups with different destination IPs

defaultGroup = indexersRouting
autoLBFrequency = 30
forceTimebasedAutoLB = true
autoLB = true

server =
sendCookedData = false
disabled = false
0 Karma

Splunk Employee
Splunk Employee

You are overriding _TCP_ROUTING key. It is same concept as normal field. If you use same field name twice for same event in transforms.conf, the last field value would be taken. It is not appending.

Maybe you try to create two tcpout group,

If defaultGroup is indexerRouting and another tcpout group is Routing-PA, can't you make use of the working example ( FORMAT= Routing-PA, indexersRouting ) ?

.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!