Getting Data In

getting typos message on universal forwarder

Path Finder
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 3: autoLBUseDNS  =  false
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 4: backoffOnFailure  =  30
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 6: blockOnQueueFull  =  true
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 9: disableBackoffOnFailure  =  false
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 11: dropClonedEventsOnQueueFull  =  5
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 17: maxPersistentQueueSizeInMegs  =  1024
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 18: persistentQueuePath  =  /usr/local/splunkforwarder/var/run/splunk/persistent_tcp_queue
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 19: readTimeout  =  300
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 22: splunktcpVersion  =  --splunk-cooked-mode-v2--
Possible typo in stanza [tcpout] in /usr/local/splunkforwarder/etc/apps/SplunkUniversalForwarder/local/outputs.conf, line 25: usePersistentQueue  =  false
There might be typos in your conf files. For more information, run 'splunk btool check --debug'
Tags (1)
0 Karma

Ultra Champion

There is no such directive as

autoLBUseDNS = false

That's why it is considered a typo. You should probably check out the docs for outputs.conf



0 Karma

Ultra Champion

just edit the outputs.conf file on the forwarder. I don't think this is automatically added/changed by starting/stopping the forwarder. Check the documentation for outputs.conf to see valid configuration options.


0 Karma

Path Finder

splunk start/restart automatically adds those entry. It's not my manual entry. where can I configure so that start/restart will not add those entry??

0 Karma

Path Finder

Here is my outputs.conf file

autoLBFrequency = 30

autoLBUseDNS = false

backoffOnFailure = 30

blockOnCloning = true

blockOnQueueFull = true

connectionTimeout = 20

disableBackoffOnFailure = false

dnsResolutionInterval = 300

dropClonedEventsOnQueueFull = -1

dropEventsOnQueueFull = -1

heartbeatFrequency = 30

indexAndForward = false

maxConnectionsPerIndexer = 2

maxFailuresPerInterval = 2

maxPersistentQueueSizeInMegs = 1024

persistentQueuePath = /usr/local/splunkforwarder/var/run/splunk/persistent_tcp_queue

readTimeout = 300

secsInFailureInterval = 1

sendCookedData = true

splunktcpVersion = --splunk-cooked-mode-v2--

sslPassword = $1$AVW9Xuv9d+0P

useACK = false

usePersistentQueue = false

writeTimeout = 300

0 Karma


to ask the obvious have you tried running

$SPLUNK_HOME/bin/splunk btool check --debug

It can actually be quite helpful.

Can you add the outputs.conf file on here?

0 Karma


can you post a copy of the outputs.conf?

0 Karma


Just glancing over a few of the lines is it possible there are some hidden characters in there?
I've had experiences where there are characters hidden out of sight which affect it but Splunk still detects them so it causes some corruption of its interpretation of it.

Perhaps try deleting those lines and typing them back in again to see if it makes any difference?

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...