Getting Data In
Highlighted

Why is my inputs.conf monitor stanza not monitoring directories recursively and no data is being indexed?

Path Finder

Hello,

I have a monitoring stanza in my inputs.conf that is intended to monitor everything that is in /var/log/splunk that ends in .log.

Reading the guides online, the triple dot ... is supposed to monitor every directory under splunk. The only thing is that nothing is getting indexed into Splunk. I'm not sure what is wrong with this stanza, any help would be greatly appreciated.

[monitor:///var/log/splunk/...]
disabled = false
recursive = true
whitelist = .log$
index = dev_test
sourcetype = splunk_test
0 Karma
Highlighted

Re: Why is my inputs.conf monitor stanza not monitoring directories recursively and no data is being indexed?

Builder

Try removing the end ... so its just
[monitor:///var/log/splunk/]

recursive = true should take care of recursing through the additional directories.

I would have expected what you did to work but who knows maybe the two recursive settings are conflicting with each other.

0 Karma
Highlighted

Re: Why is my inputs.conf monitor stanza not monitoring directories recursively and no data is being indexed?

SplunkTrust
SplunkTrust

Try this

[monitor:///var/log/splunk/.../*.log]
 disabled = false
 recursive = true
 index = dev_test
 sourcetype = splunk_test

View solution in original post

Highlighted

Re: Why is my inputs.conf monitor stanza not monitoring directories recursively and no data is being indexed?

Path Finder

This worked for me, thank you very much.

0 Karma