Getting Data In

Why are there no logs received when the universal forwarder is sending data to a search head?

Path Finder

hello, i have a problem with the universal forwarder, i set up a universal forwarder to send to a search head splunk but i have not received any log

0 Karma

Path Finder

Is your issue fixed?

0 Karma

Path Finder

If you are not able to see any logs on the Splunk search head, the possible issue can be,

  • Splunk indexer is not enabled to listen to the forwarding port.
  • The Splunk forwarder is not able to talk with the Splunk indexer.

Firstly, If you have followed every step to set up a forwarder then probably you would have completed the first step.

Secondly, you need to check the forward-server status of your Splunk forwarder using the below-given command,

splunk list forward-server

It will show the list of forward-servers configured and they will be categorized under two categories "Active forwards" and "Configured but inactive forwards".
If your forward-server is listed under the latter then, you should check your Splunk forwarder's logs to find out the particular reason.

Note:
- The log file is stored under /var/log/splunk/splunkd.log

If you see any error you can post it here, so that we can help you with that too.

You can find more information related to universal forwarder setup at the below link,
https://docs.splunk.com/Documentation/Forwarder/7.2.6/Forwarder/Configuretheuniversalforwarder

Hope it helps.

0 Karma

Path Finder

thank you for your response !
my forward server is listed under "Active forwards" but no log

0 Karma

Path Finder

Check your log file /var/log/splunk/splunkd.log
Does it show any errors?

0 Karma

Motivator

@aalaa,

Didn't get you. As UF is used to send data to Indexer not SF.
And also can you share the inputs.conf and outputs.conf file on UF.

0 Karma

Path Finder

no log also at the indexer

0 Karma

Motivator

Can you please share inputs.conf and outputs.conf on forwarder?

0 Karma

Path Finder

sorry i can't , it's confidentiel !
but can you tell me what i should do ?

0 Karma

Ultra Champion

What you need to do is some properly structured troubleshooting. If you want help with that, the only way to get that is by sharing the relevant configurations (masking confidential info where needed) and providing a lot more info on what your setup looks like.

Also take a look at the troubleshooting guide: https://docs.splunk.com/Documentation/Splunk/latest/Troubleshooting/Cantfinddata

Just saying "it doesn't work", "what should I do" makes it very difficult for anyone to help. Functioning crystal balls are still very rare 😉

0 Karma

Motivator

you can hide the confidential data and put the screenshot which can help to understand if the configuration is correct.

0 Karma

Path Finder

output.conf :
[tcpout]
defaultGroup = default-autolb-group

[tcpout:default-autolb-group]
server = ..**.*:9997

[tcpout-server://..***:9997]

0 Karma

Path Finder

inputs.conf:
[default]
host = mdelta

0 Karma

Path Finder

@vishaltaneja07011993

0 Karma

Motivator

could you please give output of

splunk display listen

on indexer

0 Karma

Motivator

check if it is pointing to 9997.

0 Karma