Getting Data In
Highlighted

Why am I not able to start splunk after installation of a Splunk universal forwarder on Solaris and getting error "invalid argument"?

Path Finder

Hi Team,

I have installed splunk universal forwarder on solaris10. When I am trying to start splunk, it's giving me invalid arguement error. Could you please advise?

I am using

splunk_home/bin/

./splunk start

also tried

./splunk start --accept-license

anything else need to be added?

0 Karma
Highlighted

Re: Why am I not able to start splunk after installation of a Splunk universal forwarder on Solaris and getting error "invalid argument"?

Esteemed Legend

Definitely reinstall. If you used a package and you reinstall and it still doesn't work, use the tarball. I always use the tarball.

0 Karma
Highlighted

Re: Why am I not able to start splunk after installation of a Splunk universal forwarder on Solaris and getting error "invalid argument"?

Path Finder

Hi Woodcock,

Thanks for your advice. Will the steps below be sufficient to install splunk fully on solaris? I mean after extracting the splunk file to a directory, does it get installed directly or do we need to run any other commands in solaris like package add etc?

tar xvzf splunk_package_name.tar.Z -C /my install directory path
 $SPLUNK_HOME/bin/splunk start --accept-license
0 Karma
Highlighted

Re: Why am I not able to start splunk after installation of a Splunk universal forwarder on Solaris and getting error "invalid argument"?

Esteemed Legend

That is how I do it. The only other main thing to consider is what user will do this. The easiest thi is to use 'root'.

0 Karma