Getting Data In

Unable to fix Bucket corruption : rawdata was truncated

stanwin
Contributor

Hiya Bucketheads

after running rebuild on a index, quite a lot of buckets were not fixed with below reason.

   failed: Error reading rawdata at offset=xxxxxx : rawdata was truncated

What is the cause of this problem .

Can those buckets be fixed at all ? The rebuild process was not successful so I have doubts?

we have previously tried the suggested disable/enable index method.

Splunk 7.2.3 (build 06d57c595b80)

    Repair entire bucket, index=cylo, tryWarmThenCold=0, bucket=/opt/splunk/data/hotwarm/cylo/db/db_1546980225_1546977033_652, exists=1, localrc=3, failReason=(entire bucket) 
 Rebuild for bkt='/opt/splunk/data/hotwarm/cylo/db/db_1546980225_1546977033_652' failed: Error reading rawdata at offset=17870904: rawdata was truncated
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...