Getting Data In

Splunk usage monitor

devilears
New Member

How do I monitor how often my users are using Splunk?

Tags (1)
0 Karma

ziegfried
Influencer

Splunk provides a few built-in dashboards for that. Take a look in the Search-App under Status -> Search Activity.

Another option is to build some searches/reports based on the events in the _audit and/or _internal index. Like this one:

index=_audit NOT user="n/a" NOT user="splunk-system-user" earliest=-30d action="login attempt" info="succeeded" | bucket span=1d _time | dedup user,_time | stats count by user | sort -count

which displays on how many days the users have logged into Splunk in the last 30 days.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...