Getting Data In

Simple search using cURL returns empty results

Path Finder

I tried following a simple cURL request based on the training video and I get no results.

I run my search:
curl -u id:password -k https://server:port/services/search/jobs -d search="search index=windows user=mylogin"

I get back a SID then search the SID for being complete.

curl -u id:password -k https://server:port/services/search/jobs/SID
see that it isDone = 1 then I l try to look at the results:

curl -u id:password -k https://server:port/services/search/jobs/SID/results

get nothing back?

when I execute the same in C# using a web client I get a method not allowed.

Thanks!

0 Karma

Path Finder

you need to add --get -d outputmode=csv (json,xml) etc

curl -k -u id:password https://server:port/services/search/jobs/SID/results --get -d "outputmode=csv" > save to file or as required.

0 Karma

Communicator

Did you try with HTTP POST method ?

curl -k -X POST -u id:password https://server:port/services/search/jobs/SID

3no

0 Karma

New Member

Even I am facing the same issue, Is it resolved? I didnt get the desiredoutput when I tried this HTTP Post method. And I am also looking for resultCount value.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!