Getting Data In

Mismatched whitelist on syslog inputs- Is there a hierarchy in which monitor stanzas are loaded?

jason0
Path Finder

Hello,

I have something strange going on.  I need to monitor logs from three different systems.  thus far I have only built one system, so there are only logs from one system present.

the three systems are:

sldvuspeedtest01p

ptdvuspeedtest01p

tsdvuspeedtest01p

while it's always tempting to go crazy with regex's, I tried the more simple version first:

[monitor:///opt/syslog/*speedtest*]
index=isp
sourcetype=speedtest
whitelist= \.log$
blacklist = (default[a-zA-Z0-9\_\-]+)\.log
#host_regex = \/opt\/syslog\/(.*)/
host_segment=3

 

but splunk will only load the syslog files if the stanza reads:

[monitor:///opt/syslog/sldvuspeedtest01p].

 

so when I tried the previous version, and then run 

"splunk _internal call /services/admin/inputstatus/TailingProcessor:FileStatus"

 

I see the following lines:

<s:key name="/opt/syslog/sldvuspeedtest01p/syslog_2023-02-24.log">
<s:dict>
<s:key name="parent">/opt/syslog/zayo_devices_new</s:key>
<s:key name="type">File did not match whitelist '^\/opt\/syslog/[^/]*\.docker/syslog_[^/]*\.log$'.</s:key>
</s:dict>
</s:key>

 

There is a stanza for that "parent", but why would splunk even confuse the two?  is there a heirarchy in which monitor stanzas are loaded in that I am running awry of?

There is also a separate stanza [monitor:///opt/syslog/*.docker/syslog_*.log] but it doesn't make sense why it would be referred to here either.

 

[monitor:///opt/syslog/zayo_devices_new]
whitelist = \.log$
blacklist = (Health[a-zA-Z0-9\_\-]+)\.log
index=z_catchall
sourcetype = zayo_routing
host_regex = zayo_devices_new/(.*)\_

 

 

Labels (1)
0 Karma

jason0
Path Finder

Hello, I failed to post that this is splunk 9.0.0.1 running in centos 7, configured as a heavy forwarder.  

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...