Getting Data In

Indexers SSL Problem

New Member

Hi guys.

I'm trying to configure my two indexers to receive data with SSL.

My inputs.conf configuration is:

# BASE SETTINGS
# [Splunktcp: // 9997]
[Splunktcp-ssl: // 9997]

# SSL SETTINGS
[SSL]
rootCA = $SPLUNK_HOME / etc / apps / MY_all_certificates / certs / MY_CA.pem
serverCert = $SPLUNK_HOME / etc / apps / MY_all_certificates / certs / MY_host.pem
sslPassword = mypassword
requireClientCert = true
# If using compressed = true, it must be set on the forwarder outputs as well.
# compressed = true

But I get an error on Indexers in splunkd:

ERROR TcpInputConfig - SSL context cannot be created two required serverCert parameter from [SSL] room. Will not open splunk to splunk (SSL) IPv4 port 9997

The problem is that it does not specify what the parameter is.

Thanks.

0 Karma

Builder

Did you ever found out what is causing this error? I've seem to have the same problem.

https://community.splunk.com/t5/Splunk-Enterprise/How-to-fix-quot-missing-serverCert-parameter-from-...

Surely I've sat the "serverCert" parameter in the SSL stanza, but nevertheless, Splunk doesn't seem to accept it.

0 Karma