Getting Data In

How to remove all duplicates?

joango
New Member

Hi, i got this query

| tstats summariesonly=t allow_old_summaries=t dc(All_Traffic.dest_port) as num_dest_port dc(All_Traffic.dest_ip) as num_dest_ip from datamodel=Network_Traffic by All_Traffic.src_ip, All_Traffic.action
| rename "All_Traffic.*" as "*"
| where num_dest_port > 100 OR num_dest_ip > 100 AND num_dest_port > num_dest_ip
| eval desv=num_dest_port / num_dest_ip
| where desv > 1 AND action!="blocked"

 

And the result is:

joango_1-1672404224411.png

My solution is half way done because it deletes most of them but not the ones that the src_ip is duplicate and the desv is diferent from one another (I don't know why). What I need is that all duplicates with the same ip are deleted.

This is what I have -->  dedup src_ip | where desv > 1 AND action!="blocked" AND action!="teardown"

Thanks!

0 Karma

bowesmana
SplunkTrust
SplunkTrust

The result table you say is after the first search. What exactly is not working after you put in the dedup src_ip and the additional where constraint?

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Make Your Machine Data AI-Ready in Splunk

Every team is getting ready for AI agents.    Watch On-Demand   In this Tech Talk, Splunk platform specialists ...

How to Break a Kubernetes Pod on Purpose and Let the AI Troubleshooting Agent Find ...

Let's say I've just rolled out a Kubernetes Deployment with a typo in the image tag. Nothing explodes. The pod ...

Splunk Add-on for Microsoft Windows 11.0.3: Parse Once, Search Faster

The updated Splunk Add-on for Microsoft Windows helps customers search Windows events faster by reducing ...