Getting Data In

How to configure inputs.conf on a Universal Forwarder to only read the current day's file that contains the date?

lmtaylor
Engager

I'm trying to configure inputs.conf to only read the current days file that contains the date. The file name changes daily. An example file name would be: localhost.2015-01-06.log. How do I configure the inputs.conf file to only read current day file on a windows server? I don't want to read all files (localhost.*.log).

somesoni2
Revered Legend

In inputs.conf, there is a property called "ignoreOlderThan". Setting this property will ensure that the files whose last modification time is older than specified values (e.g. 1d, one day) will be ignored. See more here:-

http://docs.splunk.com/Documentation/Splunk/6.1.2/admin/Inputsconf

.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!