Getting Data In

How can I merge two splunk queries together?

Taibat02230232
Loves-to-Learn

I have two Splunk queries 1 and 2 below, and both have one common email , i want the searched emails generated from the result which are email variable to be able to send an alert notification base on the search result generated email.

I need the common value to have the field with matching values in both queries which is the email , then be able to send an email alert notification

Query-1

index="aws-cloudtrail" eventName="AssumeRoleWithSAML" |fields *
| spath "requestParameters.roleArn" |search "*super*admin*"
| rex field=responseElements.subject "(?<Email>[a-zA-Z0-9]{1,8}@digitlogs.com$)"
| search Email=*
| table Email,"recipientAccountId"
| dedup Email, "recipientAccountId"

Query-2

index="okta" displayMessage="Authenticate user with AD agent"
| rename target{}.alternateId as email
| eval my_ponies=mvindex(email, -3, -2)
| eval Email=mvindex(email, 0)
| eval email=mvindex(email, 1)
| table Email email

Here are the two of them, please any input will help

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Taibat02230232,

if you're sure that one of the searches has less than 50,000 results, you can use append:

index="aws-cloudtrail" eventName="AssumeRoleWithSAML" 
| spath "requestParameters.roleArn" 
| search "*super*admin*"
| rex field=responseElements.subject "(?<Email>[a-zA-Z0-9]{1,8}@digitlogs.com$)"
| search Email=*
| table Email,"recipientAccountId"
| dedup Email, "recipientAccountId"
| append search
   index="okta" displayMessage="Authenticate user with AD agent"
   | rename target{}.alternateId as email
   | eval my_ponies=mvindex(email, -3, -2)
   | eval Email=mvindex(email, 0)
   | eval email=mvindex(email, 1)
   | table Email email
   ]
| stats 
   values(recipientAccountId) AS recipientAccountId 
   values(email) AS email 
   BY Email

otherwise you have to use a more complex search.

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...

Event Series: Mastering AI Tokenomics and Splunk Agent Observability

Beyond the Black Box: Correlating AI Performance and Tokenomics with Splunk Agent Observability   As ...